ffmpeg ERROR: libx264 version must be >= 0.78

Yesterday, I succumbed to the temptation and clicked on the Upgrade button... which means that I upgraded my Ubuntu system to 9.10. And as expected, my own build of ffmpeg got broken because of the way the binary had been built -- it was trying to load a library by its exact name and version, and as it couldn't locate it, boom! end of the story.

So I understood that I had to rebuild the binary so that it could use the latest version of the libraries which had been updated too. But I had the bad idea of running svn update on the ffmpeg sources folder before rebuilding, and as a result, the latest version can't be built with the version of libx264-dev which comes with Ubuntu 9.10, giving me the 'libx264 version must be >= 0.78' error. Booh!

As I didn't want to mess with installing custom library versions, I have just made a guesstimate of the revision number I used the last time and have gone back to that revision number:

sole@courgette:~/Applications/ffmpeg$ svn update -r 19900

After that, I just followed the very same process that I described a few posts ago.

(The reason why I didn't just select an specific SVN tag or something is because well, those guys have only the '0.5' tag under the branches directory!)